You are here

Google dropping support for XP, Vista, OSX 10.8

Subscribe to Syndicate
There has been a concentrated effort by Google and other major players in the internet to move people away from older web browsers that are built on flawed security standards. Here are some of the recent initiatives and announcements.

Theatre Manager is keeping abreast of these changes, many times on a daily basis. We continually update all of our software components to work with the latest security requirements.

What does this mean to your patrons and why is this a good thing?

You will likely receive sporadic reports from customers indicating that they are unable to purchase tickets from your web site using their browser. The answer is to help them understand that, for their own safety, commerce relies on high security. Moreover, all the current browsers are implementing this requirement and removing support for older browsers.

This is part of a concentrated effort on the part of Google, FireFox, Safari, Opera and Microsoft Edge to move people to a place of safety.

In many cases, all that a patron needs to do is switch browsers from older, no longer supported ones to the most current available.